The keyboard gets stuck for keys like < > and '|' in Linux
  • AzP October 2010

    When I'm typing the pipe char in a terminal (which is done very frequently) '|' the keymap gets screwed up, forcing me to either write it again until it resets, or typing 'reset'.

    The other two "special keys" on a Swedish keyboard often gets stuck, and starts to repeatedly print the same char again and again. These two chars are '<', '>'. Pressing any key stops the repetition/jam.

    Is this a known issue? It is of course extremely annoying, but I wouldn't abandon my wonderful TypeMatrix 2030 for it. I'm using the older PS/2 keyboards, and I have one at home and one at work. I have tried using the Belkin USB adapter, but it does not fix the issue.

  • AzP October 2010

    BTW, the jam does not only occur in a terminal, but everywhere it is written. Since I'm a programmer, the issue is very commonly occurring!

  • AzP November 2010

    Has nobody else seen this problem? No comments from TypeMatrix?

  • TypeMatrix_admin November 2010

    @AzP: Sorry for the delay in getting back to you - but this is definitely not a common problem. It is possible that this is hardware related - has this always happened with your keyboard, or has this started recently? Does it happen on this computer only or on others as well?

    In all likelihood your best bet will be to get a new USB version of the keyboard. Please email with your details, maybe we can work out some significant discount for you to upgrade.

  • Bookia November 2010

    I have the same problem. I cannot engage the "pipe" sign which I need quite frequently (I am also a programmer) nor does the number pad work. In fact, none of the function keys work at all.
    Chars '<' and '>' can be printed by using 'AltGr'+'Z' alt 'AltGr'+'X'. However, 'pipe' sign is nowhere to be found on the keyboard and can thus not be printed at alls. I also have the Swedish version of the keyboard with PS/2.
    This is not at all satisfactory given that I've paid a lot of money for this keyboard.

  • ola December 2010

    I have had similar problems. Mine disappeared when I replaced or removed the USB to PS2 adapter.

  • Bookia December 2010

    Ola, which adapter are you using that has worked with this keyboard? I have a modern laptop that only has USB so I have to have an adapter.

  • ola December 2010

    Bookia I think I used the one that came with the keyboard but one time I tried another and got the same symptoms you describe.

  • Bookia December 2010

    Ok, I didn't get any adapter along with the keyboard. :-/
    Can anyone from TypeMatrix please tell me exactly what kind of adapter (brand and availability) that Ola is talking about!?

  • ola December 2010

    Bookia I'll look at it when I come back home (some days).

  • TypeMatrix_admin December 2010

    @Bookia: Unfortunately PS/2 to USB adapters are made of varying... "quality" that doesn't necessarily get reflected in the price. You should have received one that we have tested to work with your keyboard. If you didn't, please email referencing this forum and we will see if we can just mail one out to you and hopefully resolve this issue. However, we are aware that some of the older PS/2 models just have this issue with some computer systems. Please email us and we'll see what we can work out for you.

  • AzP December 2010

    I'm glad to see that other people are seeing the same issues as I am (even though I'd prefer to not see it at all ;)). As I mentioned in the first post, I'm using the Belin adapter, which at the time was sent to me from TypeMatrix (I was in contact with Mary Webber) because it would hopefully solve my problem.
    Sadly it didn't solve it though.

    Another issue - which is much more severe - I'm seeing is that in Windows (both XP and 7) the ctrl, shift or alt keys somehow get 'stuck' in the software. I have not been able to reproduce it in any sensible way, it just happens every now and then. To fix it I either have to reboot the machine or press the different keys over and over again, in different combinations, and hopefully that makes it go away after a couple of minutes.
    I don't know if it has something to do with me using the Svorak layout, but it does happen both with the Svorak keymap (which you load into language bar) and the Svorak Remapping software (which kind of hijacks the keystrokes and translates them above the OS level).

    Just like Bookia, I have seen that the num-pad sometimes doesn't work in Windows. But it seems to be pretty consistent, either it works on a machine or it doesn't. I have not seen it switch between working and non working.

    Can all of these issues be driver issues for the PS/2 (since they have no drivers I guess...)?

    Edit: I'm sorry, I just realized I haven't answered your questions. Talk about a bad user ;)

    - "has this always happened with your keyboard, or has this started recently? Does it happen on this computer only or on others as well?"

    Well, I think it has always been happening. I have had the keyboard for 3.5 years now, and the issue has always been there. I'm glad to say that Linux/Gnome now has built-in support for the 2030 (yaaay!), but I don't see that it has fixed the problem.
    Since I have 2 keyboards (one at home and one at work) I don't think it is a hardware-related issue.

    - "In all likelihood your best bet will be to get a new USB version of the keyboard. Please email with your details, maybe we can work out some significant discount for you to upgrade"

    Thank you, I'll get back to you via e-mail, and hopefully we can figure something out. I really like the keyboard and recommend it to everybody, it is just these three issues that keeps annoying me.

  • Bookia December 2010

    I will email support, I however just wanted to note that I am using Linux, but have tested using this keyboard in Windows as well and had the exact same problems in both OS. I am using QWERTY setup on the keyboard.
    I hope the adapter will help, in any case I will write here and tell you all how it went. Fingers crossed now! :)

  • AzP January 2011

    How did it go Bookia? Any improvements?

  • Hey again everyone. Can you please check the solutions offered in the "The keyboard don't work for key < > in Windows 7 with french AZERTY skin" thread? It seems we're having two very similar threads going, and we believe the solutions offered there may fix the issues for many of you here:

    If that still doesn't resolve your troubles, please post back. Thanks,


  • AzP February 2011

    Hi again
    Regarding the other thread: I'm using the old Typematrix (PS/2) so I don't have the 102 key mode on it. But if I do try to press fn + F2, nothing happens. The numpad works after trying out the fn + F4 (n.lock), but the < > or | symbols still doesn't work.

  • TypeMatrix_admin February 2011


    We really feel the right way to get your troubles resolved is to get you upgraded to the newer USB version of the keyboard (we just checked and found an old email thread with you from 2007! asking about the USB version). Please contact us, we're very willing to work out a decent discount to get you upgraded and this issue resolved. Thanks!


  • AzP February 2011

    Hi, and thank you for the reply! I was just reading through that old e-mail myself, funny that you mentioned it =)

    I'll send you an e-mail immediately!

  • AzP March 2011

    Hi again guys!

    I've been using my new keyboard for a week now and the problems we have talked about above are gone! The keyboard is great, with the same good feel as the old one. Even perhaps a bit better =)

    But I am seeing one new issue, which reminds me of the old ones. The TAB key sometimes stops working, and the way to fix it is simply to detach and insert the usb-cable from the computer. Then the tab functionality comes back again.

    It doesn't help to set/unset the keyboards 102 mode.

    I'm using Windows 7 on a MacBook Pro, but I guess that shouldn't matter since it's all Intel now anyways.

    Have you seen this issue before?

  • @AzP:

    Hello again. We're glad that the issues we've been working on got resolved by switching to the most current version.

    The tab issue you're describing is a new one, but Windows 7 on a Mac is probably not a very usual setup that our customers use.

    If you're running Windows 7 in a virtualized environment on top of the Mac OS it's always possible that special keys like tab get swallowed somewhere along the translation line. That's very difficult to track down without knowing the detailed specifics of your particular setup. We're using the current TypeMatrix on Windows 7 ourselves (although not on Mac hardware) and we've never encountered this one. The CPU isn't usually what controls USB i/o usually, so I don't think that should really matter.

    The tab key is the same on all layers so I wouldn't think that switching between layers would affect the processing of it in the keyboard hardware.

    I'd like to give some more pointers but it's difficult when I don't understand your setup. It's important that the computer boot up with NumLock enabled, although tab shouldn't be directly affected by that. Next time this happens, can you try Fn + O (that's o as in oscar in qwerty or R on the dvorak skin - the key at the top left of the numpad section)? That should also send the tab scan code to the computer.

    If that works, then it's possible that there's something wrong with the physical Tab key. Either way it may be helpful to disassemble and clean the tab key, just to make sure there is no dirt or obstruction lodged underneath it. If it doesn't work, then I'm inclined to believe that this is a software issue.

    Since this is all very specific to you, would you mind emailing us with the details and we can try to sort out what's going on with this issue?


  • AzP March 2011

    Sure, I can send you an email regarding the issue.

  • xurxosanz May 2011

    I've just experienced the missing Tab key reported by @AzP. I'm on Ubuntu 11.04 x64 with Dvorak layout.

    Anyway, unplugging worked

    Next time I'll try the Fn + O (H actually at dvorak-ES layout) and report if it works.


  • AzP June 2011

    I have the same issue on another Win7 install right now. I have to unplugg/plug in about once or twice a day, but it might be because I'm such a heavy alt+tab user. It always happens when I alt+tab between programs.

  • bonega July 2011

    I have the tab issue on three different 2030 keyboards...
    This is on: Win7, winxp, Ubuntu and Slackware.

    It might be a hardware design problem...

    Probably should have sent the keyboards back, but this is what I get for being lazy.

  • AzP August 2011

    I also have the same issues on 2 different keyboards, on Windows 7 (one 32 bit and one 64 bit) and on Linux (Gentoo).

    It must be a hardware issue (probably design problem), and I would be glad to get some more feedback from TypeMatrix regarding the problem. I got my keyboards with a discount since I bought them to replace my PS/2 keyboards which had other issues, so it is a bit frustrating that new issues are popping up.
    I really like the keyboards (and promote them to everybody) so it would be nice to not have to say "They rock!.. .but sadly they can be a bit buggy".

  • TypeMatrix_admin September 2011

    A quick update on the tab issue:
    Thanks to your descriptions we've finally been able to reproduce the issue. That unfortunately means that this entire batch of keyboards is likely affected. We've started working with our factory to see if we can track down the issue (and as you point out it's likely a firmware issue). There will most likely not be a real quick fix here, but we wanted to publicly acknowledge that yes, there is an issue and we're working on it. Fortunately it only affects heavy users of the tab key and there is a workaround (unplugging the keyboard), but we understand that those of you using that key a lot are frustrated. We'll post back as soon as we know more.


  • AzP September 2011

    Thank you for your answer, it really makes a difference for me that you acknowledge it, and was able to reproduce it!
    If it's a firmware issue, do you think it could be possible for a tech-savvy user to reflash the firmware with a fix?

  • TypeMatrix_admin September 2011

    Unfortunately there will most likely not be a way to flash the firmware for users - the keyboards weren't designed to allow this post-production.
    We're working with the factory and will post an update on what we can do for you once we get the issue resolved, hopefully in the new batch of keyboards that is forthcoming.
    Thanks for your patience,

  • A quick update on the tab issue: our factory reported that they have identified the issue, and were able to correct it on the newly ordered batch of keyboards. Unfortunately this delayed the batch (which is why were now out of Dvorak and Qwerty labeled keyboards), but it was important to get this resolved.

  • AzP October 2011

    Great to hear about the progress! I'm glad I was able to help with finding the bug, so you were able to root it out and kill it =)

  • AzP November 2011

    Has everything been worked out now? Are the new keyboards on their way? Is it possible to get a keyboard replaced with the new ones (even if it is at a certain cost)?

  • TypeMatrix_admin November 2011

    Unfortunately the factory has missed the originally scheduled delivery date of November 3rd. They've told us they are a little behind on their orders, and unfortunately that's as much information as we have at the moment. We're expecting them sooner than later, but we can't give any guaranteed dates at this point. We'll keep you posted.

    We do plan to replace keyboards for people like you that have posted here or emailed us about the problems they are having.


  • AzP January 2012

    Any news about this?

  • The new keyboards cleared customs and should be arriving at our warehouse today. About the first thing we'll check is the tab issue. We'll report back shortly.


  • AzP February 2012

    *Friendly reminder*

  • AzP February 2012

    Any news, it's been a month since you received the keyboards?

  • Beyertech February 2012

    I wanted to order a qwerty layout typematrix keyboard but since they were out of stock I ordered a blank keyboard instead. This is about two months ago. Now that I have a blank keyboard with an unresponsive tab key because of a faulty production I have to say I feel kind of cheated of the product I really wanted. In my current work situation its not a problem to reach behind a screen and unplug the keyboard, but on a regular computer, getting down under my desk to unplug this keyboard once in a while is terribly annoying. I really enjoy the typematrix keyboard, rather I love it, but frankly I want a keyboard that works. Considering the cost, asking for a functioning product should not be too much. I am very much looking forward to the official response to this.

  • TypeMatrix_admin February 2012

    @AzP you should have been contacted by email - did you not receive that communication? If not, please email us at and we will follow up with you.

    please email us directly at and include all the above details and those of you your order. Let's see if we can figure out a solution for you.

    The official response is as before - We acknowledge there was a problem, and will work with any customer that runs into trouble with it to find a resolution.


  • AzP February 2012

    I have received the e-mail now! Thank you very much!

  • flv May 2012

    Hi, it seems I encounter the TAB problem too. I noticed it happens when I use the alt-tab key shortcut (I don't know what's it called, it's left to the spacebar).
    Is there any way to correct this manually, like with a firmware upgrade? I guess it's risky if that's even possible for a usb keyboard.

    Still, this is sad I can't use that shortcut anymore, it's quite useful, when it doesn't mess with the TAB keys! :D
    (oh and yes, Fn+O doesn't work too, so I guess it's a software problem)

    Anyway, I'm very happy with my keyboard. Thanks Typematrix!

  • @flv:
    If you're having issues with the TAB problem, please email and let's see what we can work out for you.


This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

In this Discussion